Temporary phone number for Support

Incident Report for ASPEX - Statuspage

Resolved

This incident has been resolved.
Posted Feb 20, 2020 - 13:42 CET

Update

Our provider is still working on the problem. To reach Aspex via phone, please use number 03 304 41 90.
Posted Feb 20, 2020 - 11:05 CET

Identified

Due to technical problems Aspex Support will not be available on the normal number (03 201 70 07)

You can contact support via email or chat, and on the number 03 304 41 90

The issue should be resolved around 11:00
Posted Feb 20, 2020 - 10:03 CET
This incident affected: ASPEX Website.